ruby1.9.3_1.9.3.194-8.1+deb7u5_all.deb


Advertisement

Description

ruby1.9.3 - Interpreter of object-oriented scripting language Ruby, version 1.9.3

Property Value
Distribution DEB Universal
Repository OpenNMS Unstable amd64
Package name ruby1.9.3
Package version 1.9.3.194
Package release 8.1+deb7u5
Package architecture all
Package type deb
Installed size 205 B
Download size 169.05 KB
Official Mirror debian.opennms.org
Ruby is the interpreted scripting language for quick and easy
object-oriented programming.  It has many features to process text
files and to do system management tasks (as in perl).  It is simple,
straight-forward, and extensible.
Ruby uses two parallel versioning schemes: the `Ruby library compatibility
version' (1.9.1 for this package), which is similar to a library SONAME, and
the `Ruby version' (1.9.3 for this package). Ruby packages in Debian are
named using the Ruby library compatibility version, which is sometimes
confusing for users who do not follow Ruby development closely. This package
depends on the ruby1.9.1 package, and provides compatibility symbolic links
from 1.9.3 executables and manual pages to their 1.9.1 counterparts.

Alternatives

Package Version Architecture Repository
ruby1.9.3_1.9.3.194-8.1+deb7u5_all.deb 1.9.3.194 all OpenNMS Unstable
ruby1.9.3_1.9.3.194-8.1+deb7u5_all.deb 1.9.3.194 all OpenNMS Testing
ruby1.9.3_1.9.3.194-8.1+deb7u5_all.deb 1.9.3.194 all OpenNMS Testing
ruby1.9.3_1.9.3.194-8.1+deb7u5_all.deb 1.9.3.194 all OpenNMS Stable
ruby1.9.3_1.9.3.194-8.1+deb7u5_all.deb 1.9.3.194 all OpenNMS Stable
ruby1.9.3 - - -

Requires

Name Value
ruby1.9.1 >= 1.9.3.194-8.1+deb7u5

Download

Type URL
Binary Package ruby1.9.3_1.9.3.194-8.1+deb7u5_all.deb
Source Package ruby1.9.1

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    deb http://debian.opennms.org/ unstable main
  2. Install GPG key of the repository:
    # wget -O - http://debian.opennms.org/OPENNMS-GPG-KEY | sudo apt-key add -
  3. Update the package index:
    # sudo apt-get update
  4. Install ruby1.9.3 deb package:
    # sudo apt-get install ruby1.9.3

Files

Path
/usr/bin/erb1.9.3
/usr/bin/gem1.9.3
/usr/bin/irb1.9.3
/usr/bin/rake1.9.3
/usr/bin/rdoc1.9.3
/usr/bin/ri1.9.3
/usr/bin/ruby1.9.3
/usr/bin/testrb1.9.3
/usr/share/doc/ruby1.9.3/NEWS.Debian.gz
/usr/share/doc/ruby1.9.3/NEWS.gz
/usr/share/doc/ruby1.9.3/README.gz
/usr/share/doc/ruby1.9.3/changelog.Debian.gz
/usr/share/doc/ruby1.9.3/changelog.gz
/usr/share/doc/ruby1.9.3/copyright
/usr/share/man/man1/erb1.9.3.1.gz
/usr/share/man/man1/gem1.9.3.1.gz
/usr/share/man/man1/irb1.9.3.1.gz
/usr/share/man/man1/rake1.9.3.1.gz
/usr/share/man/man1/rdoc1.9.3.1.gz
/usr/share/man/man1/ri1.9.3.1.gz
/usr/share/man/man1/ruby1.9.3.1.gz
/usr/share/man/man1/testrb1.9.3.1.gz

See Also

Package Description
sun-java5-bin_1.5.0-17-0.1_amd64.deb Sun Java(TM) Runtime Environment (JRE) 5.0 (architecture dependent files)
sun-java5-demo_1.5.0-17-0.1_amd64.deb Sun Java(TM) Development Kit (JDK) 5.0 demos and examples
sun-java5-doc_1.5.0-17-0.1_all.deb Sun JDK(TM) Documention -- integration installer
sun-java5-fonts_1.5.0-17-0.1_all.deb Lucida TrueType fonts (from the Sun JRE)
sun-java5-jdk_1.5.0-17-0.1_amd64.deb Sun Java(TM) Development Kit (JDK) 5.0
sun-java5-jre_1.5.0-17-0.1_all.deb Sun Java(TM) Runtime Environment (JRE) 5.0 (architecture independent files)
sun-java5-source_1.5.0-17-0.1_all.deb Sun Java(TM) Development Kit (JDK) 5.0 source files
tomcat4-admin_4.1.31-3_all.deb Java Servlet engine -- admin web interfaces
tomcat4-webapps_4.1.31-3_all.deb Java Servlet engine -- documentation and example web applications
tomcat4_4.1.31-3_all.deb Java Servlet 2.3 engine with JSP 1.2 support
Advertisement
Advertisement